So-net無料ブログ作成
検索選択

IAStorDataMgrSvcの謎 [ソフトウェア/PC関係]

なんだか奇妙な話。

メイン・マシンのWindows 7の動作が,どうも重いので,タスク・マネージャをチェックしてみた。[プロセス]タブで,「すべてのユーザーのプロセスを表示」を押してから,CPU利用率の高い順にソートしたところ,「IAStorDataMgrSvc.exe」というプロセスが,40%以上のCPUを食っている。しかも,一時的なものではなく,延々とCPUを食い続けているのだ。これじゃぁ,動作が重くなるはずである。で,一体これは何なのか。

「IA」って接頭辞からある程度想像は付いたのだが,取り敢えずプロセスのプロパティをチェックしてみると,「Intel(R) Rapid Storage Technology」というディレクトリの下にある実行ファイルだということが分かった。HDDのアクセスを高速化するらしい,Intel純正ユーティリティ(ドライバ)のひとつですな。しかし,高速化するためのものが,CPUを食い潰してしまうのでは本末転倒。以前はこんなことなかったはずなのに,どういうわけだろうか。

バージョンが古くなってしまったのかと思って,タスク・トレイのアイコンを見てみると,Rapid Storage Technology(以下,RST)のアイコンのツールチップに,"Not running"とか書かれている。おや? さらに,アイコンをクリックして出てくるメニューから,"Open Application"を選択すると,エラーになってアプリケーションが起動しない。これは一体どういうことなのか。

仕方ないので,新しいバージョンでもインストールしてみようと,最新のらしい,バージョン13.1.0.1058をダウンロードしてきた。ところが,実行してみると,.NET Framework 4.5が必要だという。ドライバのインストールごときのために,なんで.NET Frameworkの新しいバージョンなんてインストールしないといけないんだろう。釈然とはしないが,言われるままにインストールして,システムを再起動。もう一度RSTのインストーラを起動すると,「このプラットフォームはサポートされていません」だと。バカにしてるのか?

軽く殺意を覚えつつも,Readmeをチェック。デバイス・マネージャで,「Intel(R) SATA RAID controller」か「Intel(R) SATA AHCI controller」のどちらかがあるかチェックしろと? ところが,これが見当たらない。AHCIは,以前見たことがあったはずなのだが,今はどこにもない。AHCIで構成してあるはずなのに何故?

もしや,BIOSの設定がリセットされているのでは? ふと思い付いて,再起動し,BIOSの設定画面を開く。すると,あろうことか,SATAのモードが,AHCIではなくIDEになっていた...。恐らく,何かの時にBIOS設定がリセットされてしまったのだろう。デバイス・マネージャに出て来ない訳だ。早速,AHCIにセットし直して,再起動。タスク・トレイのアイコンのツールチップに"Not running"も出なくなり,アプリケーションも起動するようになった。タスク・マネージャのIAStorDataMgrSvc.exeも,ほとんどCPUを消費しなくなった。ひとまず一件落着...ではあるが,なんとも人騒がせな話である。

なお,RSTの最新バージョンは,AHCIを有効な状態にしてもインストールできなかった。原因は不明。まぁ,もはや必要もないので,良いのだけれど。結局,.NET Framework 4.5のインストールは,完全に余計な手間だったというわけで,ちょっと腹立たしくもあるが。。


nice!(1)  コメント(1)  トラックバック(0) 

nice! 1

コメント 1

NO NAME

とても参考になりました
確かにAHCIからIDEに変わっていました・・・
おかげさまで常に使用率30%だったのが改善できました
ありがとうございました
by NO NAME (2014-08-24 18:50) 

コメントを書く

お名前:
URL:
コメント:
画像認証:
下の画像に表示されている文字を入力してください。

※ブログオーナーが承認したコメントのみ表示されます。

トラックバック 0

この記事のトラックバックURL:
※ブログオーナーが承認したトラックバックのみ表示されます。
※言及リンクのないトラックバックは受信されません。